The given key was not present in the dictionary

The given key was not present in the dictionary

Cause:

While browsing through Document Types you may encounter this error. The cause for this is the User profile (for e.g. Superadmin or user Bob)  or the DB profile in GLOBODOX has gone corrupted

Solution :

You will have to perform the below steps on the machine on which GLOBODOX is installed in the Server mode.

FIXING THE DB PROFILE

To solve this issue follow the steps below...
  • Please make sure that you back up the GLOBODOX Databases.
  • Close GLOBODOX on all the machines
  • Open the Windows Command Line window.
  • You can open the Windows Command Line by opening the Run dialog (Windows button + R) and in the RUN dialog type cmd. Press Enter, the Windows Command Line Window will be launched.
  • In the Command Line window type the following at the cursor...
                "C:\Program Files (x86)\Globodox Desktop\Globodox.exe" /resetdbprofile /dbid=1
                (Assuming GLOBODOX is installed in the default location)

Note: By default the ID for MainDB is 1. if you are getting this error in another DB then you will need to check the DB ID for for this DB. To  know the ID go to... Settings >> DB List. The DB IB will displayed in the List View for each DB, If the ID column is not displayed then you will have right click on the column header and add the ID column.

  • Now, hit the Enter key.
  • You will be prompted to login with the credentials of the superadmin user. (Incase case of Active Directory you will only need to click the Login button)
  • You will receive a confirmation message 'Command line tasks performed successfully'
  • Now start GLOBODOX and check if the issue is resolved.

In case the issue persists, then you will have  to follow the instructions below...


FIXING THE USER PROFILE

  • In the Command Line window type the following at the cursor if you are facing the issue for a particular user...
             "C:\Program Files (x86)\Globodox Desktop\Globodox.exe" /resetuserdbprofile /dbid=1 /username=Bob
           
(where Bob is the username for a user in GLOBODOX who currently faces the issue)

  • In the Command Line window type the following at the cursor if you are facing the issue for all the users...

    "C:\Program Files (x86)\Globodox Desktop\Globodox.exe" /resetuserdbprofile /dbid=1 /username=#all                                                                                               
Note: By default the ID for MainDB is 1. if you are getting this error in another DB then you will need to check the DB ID for for this DB. To  know the ID go to... Settings >> DB List. The DB IB will displayed in the List View for each DB, If the ID column is not displayed then you will have right click on the column header and add the ID column.
  • Now, hit the Enter key.
  • You will be prompted to login with the credentials of the superadmin user. (Incase case of Active Directory you will only need to click the Login button)
  • You will receive a confirmation message 'Command line tasks performed successfully'
  • Now start GLOBODOX and check if the issue is resolved.
You can drop in an email to support@globodox.com, in case none of the above commands resolves your issue.